NEW: Search The Forums

Loading

Bobbin won't wind when using pedal

puccho's picture

Bobbin won't wind when using pedal (post #40381)

I recently got a used Janome Plaire. The seller said it had been tested for basic functionality. 

I just tried to use it and found that the bobbins won't wind. If I use the hand wheel they'll wind, but not if I use the pedal. I don't want to wind them up only using the wheel - my wrist will die!

The pedal works to sew normally, and the machine came with several bobbins that had thread wound on to them from the previous owner - so I assume it worked at some point. 

  • This machine doesn't have a clutch thing in the hand wheel - it's just a solid lump thats only function is to move the needle.
  • When the bobbin winder is to the left, the wheel turns as normal. When it's to the right, it makes a clicking noise. Not sure if this is normal.
  • I've tried with the feed dogs up/down
  • I've tried changing the tension
  • The stitch length is normal (2) stich type is normal
  • The thread is on the bobbin exactly as in the instructions. The bobbin winder is pushed to the right and clicked in.
  • When I turn the wheel to wind the thread on to the bobbin, the needle and feed dogs move. This was normal in my last Janome.

I will love anyone who can solve this problem !! <3

CarolFresia's picture

Consult a dealer (post #40381, reply #1 of 2)

Hi,

I can't solve your problem, I'm sorry to say, and I think you'd probably be best to consult a Janome dealer. This sounds like a mechanical issue of some sort, and one that might be pretty easy to solve.

Good luck!

Carol Fresia, Threads Technical Editor

Pattiann42's picture

Bobbin Won't Wind (post #40381, reply #2 of 2)

Your post indicates this is a used machine.  Is there a manual?  If you still cannot wind the bobbins according to the instructions in the manual, you may want to return the machine, or use a stand alone bobbin winder.

Best wishes for a successful outcome.